parallel_align_seqs_pynast.py not working on EC2

The pick_open_reference_otus.py script finished for GOM Illumina reverse reads clustered at 96% – however – the parallel_align_seqs_pynast.py script was not working…the log file indicated the script had been executed, but top command showed nothing running. Tried running the script manually (below command), both with and without the -T flag. Also didn’t seem to work – the paralell jobs would start but then would all end for some reason..

parallel_align_seqs_pynast.py -i /home/ubuntu/gom_data/uclust_openref96_ref_27Aug/rep_set.fna -o /home/ubuntu/gom_data/uclust_openref96_ref_27Aug/pynast_aligned_seqs_manual -O 8 -t /home/ubuntu/gom_data/99_Silva_111_rep_set_euk_aligned.fasta -a uclust -p 70.0

So instead of worrying about that for now, I’m going to move on to 99% clustering on the reverse reads to see how long this takes. (note: the 96% cutoff finished overnight, for a ~1.5GB file on an m2.4xlarge instance)

pick_open_reference_otus.py -i /home/ubuntu/gom_data/GOM_concat1.7_rev_demulti_1to12_2.fna -o /home/ubuntu/gom_data/uclust_openref99_28Aug -r /home/ubuntu/gom_data/99_Silva_111_rep_set_euk.fasta --parallel -O 10 -s 0.1 -p /home/ubuntu/gom_data/qiime_parameters_uclust99gom_aws28Aug.txt --prefilter_percent_id 0.0
Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: